Skip to content

Instantly share code, notes, and snippets.

View webdevsuperfast's full-sized avatar
🏠
Working from home

Rotsen Mark Acob webdevsuperfast

🏠
Working from home
View GitHub Profile
@webdevsuperfast
webdevsuperfast / run.sh
Last active October 22, 2022 05:33 — forked from xanderificnl/run.sh
Install recursive mono font on Fedora
#!/bin/sh
sudo dnf install -y wget p7zip curl
[[ ! -d ~/.fonts ]] && mkdir -p ~/.fonts
wget "$(curl "https://www.recursive.design" | grep -o 'https://github.com/.*.zip' | head -n1)" -O /tmp/recursive-fonts.zip
( cd ~/.fonts ; 7za e -y -r -i\!*.ttf /tmp/recursive-fonts.zip )
@webdevsuperfast
webdevsuperfast / .gitlab-ci.yml
Created April 1, 2022 02:17 — forked from qutek/.gitlab-ci.yml
[Gitlab CI With Rsync] Auto deploy gitlab CI with rsync
# https://gitlab.com/help/ci/quick_start/README
# https://docs.gitlab.com/ee/ci/introduction/
# https://docs.gitlab.com/ee/ci/yaml/
image: dpolyakov/docker-node-latest-with-rsync:latest
# before_script:
# - apt-get update -qq
# - apt-get install -qq git
@webdevsuperfast
webdevsuperfast / Ionic Android Development on WSL.md
Created March 20, 2022 09:49 — forked from fedme/Ionic Android Development on WSL.md
Ionic Android Development on WSL (Windows Subsystem for Linux)

Ionic Android Development on WSL

Installing the required software

Execute the following commands to install Node, npm, git, Java, Ionic, Cordova and Angular CLI:

cd ~
sudo apt update
sudo apt upgrade
@webdevsuperfast
webdevsuperfast / qemu_fedora.md
Last active March 7, 2022 03:10 — forked from Jatapiaro/qemu_ubuntu.md
How to install QEMU on MacOS Catalina and install a Fedora VM

Install QEMU on OSX

QEMU requires brew in OSX, so we need to install brew first.

Installing Brew

To install brew we need to have the developer tools enabled in our system. In order to install those tools, we have two options.

  1. Download Xcode form the AppStore
  2. In your terminal run the following command: xcode-select --install
@webdevsuperfast
webdevsuperfast / Adguard.js
Created November 13, 2021 01:51 — forked from LeiHao0/Adguard.js
Batch add block list in Adguard Home
list = [
"https://raw.githubusercontent.com/PolishFiltersTeam/KADhosts/master/KADhosts.txt",
"https://raw.githubusercontent.com/FadeMind/hosts.extras/master/add.Spam/hosts",
"https://v.firebog.net/hosts/static/w3kbl.txt",
"https://raw.githubusercontent.com/matomo-org/referrer-spam-blacklist/master/spammers.txt",
"https://someonewhocares.org/hosts/zero/hosts",
"https://raw.githubusercontent.com/VeleSila/yhosts/master/hosts",
"https://winhelp2002.mvps.org/hosts.txt",
"https://v.firebog.net/hosts/neohostsbasic.txt",
"https://raw.githubusercontent.com/RooneyMcNibNug/pihole-stuff/master/SNAFU.txt",
@webdevsuperfast
webdevsuperfast / doh.rsc
Created June 3, 2021 01:33 — forked from Lillecarl/doh.rsc
MikroTik Cloudflare anti phising DOH
{
/tool fetch url=https://curl.haxx.se/ca/cacert.pem
/certificate import file-name=cacert.pem passphrase=””
/ip firewall layer7-protocol
add name=security.cloudflare-dns.com regexp=security.cloudflare-dns.com
/ip dns
set allow-remote-requests=yes cache-max-ttl=1h servers=1.1.1.2,1.0.0.2,2606:4700:4700::1112,2606:4700:4700::1002 use-doh-server=https://security.cloudflare-dns.com/dns-query verify-doh-cert=yes
/ip firewall filter
add action=drop chain=output comment="drop dns output if not looking for cloudflare DOH servers." dst-port=53 layer7-protocol=!security.cloudflare-dns.com out-interface-list=WAN protocol=tcp
add action=drop chain=output comment="drop dns output if not looking for cloudflare DOH servers." dst-port=53 layer7-protocol=!security.cloudflare-dns.com out-interface-list=WAN protocol=udp
// modifys contact form 7's default select value of --- to Please select...
function my_wpcf7_form_elements($html) {
$text = 'Please select...';
$html = str_replace('<option value="">---</option>', '<option value="">' . $text . '</option>', $html);
return $html;
}
add_filter('wpcf7_form_elements', 'my_wpcf7_form_elements');
// Modify multiple selects
function my_wpcf7_form_elements($html) {
@webdevsuperfast
webdevsuperfast / README.md
Created June 19, 2020 05:10 — forked from hofmannsven/README.md
Storing WordPress files and database with WP-CLI on the server.
@webdevsuperfast
webdevsuperfast / wordpress-base-custom-data.php
Created September 9, 2019 04:20 — forked from paulund/wordpress-base-custom-data.php
A PHP class to handle CRUD functionality in WordPress default tables.
<?php
/**
* Abstract class which has helper functions to get data from the database
*/
abstract class Base_Custom_Data
{
/**
* The current table name
*
* @var boolean