Skip to content

Instantly share code, notes, and snippets.

@unixdj
Last active January 31, 2018 11:05

Revisions

  1. unixdj revised this gist Jul 10, 2013. 1 changed file with 1 addition and 1 deletion.
    2 changes: 1 addition & 1 deletion :etc:config:network
    Original file line number Diff line number Diff line change
    @@ -5,7 +5,7 @@ config interface 'loopback'
    option netmask '255.0.0.0'

    config globals 'globals'
    option ula_prefix 'fcxx:xxxx:xxxx::/48'
    option ula_prefix 'fdxx:xxxx:xxxx::/48'

    config interface 'lan'
    option ifname 'eth0'
  2. unixdj revised this gist Jul 10, 2013. 1 changed file with 0 additions and 2 deletions.
    2 changes: 0 additions & 2 deletions :etc:config:wireless
    Original file line number Diff line number Diff line change
    @@ -19,8 +19,6 @@ config wifi-iface
    option encryption psk2

    config wifi-iface
    option device radio0
    option network wan
    option device radio0
    option network wan
    option mode sta
  3. unixdj created this gist Jul 10, 2013.
    19 changes: 19 additions & 0 deletions :etc:config:network
    Original file line number Diff line number Diff line change
    @@ -0,0 +1,19 @@
    config interface 'loopback'
    option ifname 'lo'
    option proto 'static'
    option ipaddr '127.0.0.1'
    option netmask '255.0.0.0'

    config globals 'globals'
    option ula_prefix 'fcxx:xxxx:xxxx::/48'

    config interface 'lan'
    option ifname 'eth0'
    option type 'bridge'
    option proto 'static'
    option ipaddr '192.168.1.1'
    option netmask '255.255.255.0'
    option ip6assign '60'

    config interface 'wan'
    option proto 'dhcp'
    29 changes: 29 additions & 0 deletions :etc:config:wireless
    Original file line number Diff line number Diff line change
    @@ -0,0 +1,29 @@
    config wifi-device radio0
    option type mac80211
    option channel 11
    option hwmode 11ng
    option path 'platform/ar933x_wmac'
    option htmode HT20
    list ht_capab SHORT-GI-20
    list ht_capab SHORT-GI-40
    list ht_capab RX-STBC1
    list ht_capab DSSS_CCK-40
    #option disabled 1

    config wifi-iface
    option device radio0
    option network lan
    option mode ap
    option ssid PocketNet
    option key 'password'
    option encryption psk2

    config wifi-iface
    option device radio0
    option network wan
    option device radio0
    option network wan
    option mode sta
    option ssid Upstream
    option key 'password'
    option encryption psk2