Created
March 3, 2014 20:31
-
-
Save dhh/9333991 to your computer and use it in GitHub Desktop.
This file contains hidden or bidirectional Unicode text that may be interpreted or compiled differently than what appears below. To review, open the file in an editor that reveals hidden Unicode characters.
Learn more about bidirectional Unicode characters
class GroupersController < ApplicationController::Base | |
def create | |
@grouper = Grouper.new(leader: current_member) | |
if @grouper.save | |
ConfirmedGrouperEmails.new(@grouper).deliver | |
AssignBarForGrouper.enqueue(@grouper.id) | |
redirect_to home_path | |
else | |
render :new | |
end | |
end | |
end | |
# app/mailers/confirmed_grouper_emails.rb | |
class ConfirmedGrouperEmails | |
def initialize(grouper) | |
@grouper = grouper | |
end | |
def deliver | |
LeaderMailer.grouper_confirmed(member: @grouper.leader.id).deliver | |
WingMailer.grouper_confirmed(wings: @grouper.wings.pluck(:id)).deliver | |
AdminMailer.grouper_confirmed(grouper: @grouper.admin.id).deliver | |
end | |
end |
@tel I think the improvement is readability: .deliver(grouper)
comes across as delivering a grouper, while .deliver
is read as simply delivering whatever it was called on.
@shime 👍
Put another way, passing the argument to a class method is not "exemplary" (a la Sandi Metz). So future development efforts (often by other devs) are likely harmed, since this pattern resists refactoring.
Sign up for free
to join this conversation on GitHub.
Already have an account?
Sign in to comment
In this specific example you're right, there's no improvement. But if you were to add other methods beyond deliver, which also make use of
@grouper
, then you get the improvement of not having to pass the parameter around constantly. It's not really any different than preferring"hello".upcase
to something likeuppercase("hello")