Last active
November 26, 2022 21:55
-
-
Save Torstein-Eide/5022669b4dbf31204b3b21b278a365f7 to your computer and use it in GitHub Desktop.
Getting OSPF to work with Pfsense FRR, linux quagga, wireguard
This file contains hidden or bidirectional Unicode text that may be interpreted or compiled differently than what appears below. To review, open the file in an editor that reveals hidden Unicode characters.
Learn more about bidirectional Unicode characters
### on linux box running quagga | |
interface eth0 | |
! | |
interface lo | |
! | |
interface wg0 | |
## This need to set, or it will use broadcast | |
ip ospf network non-broadcast | |
### This need to match | |
ip ospf hello-interval 5 | |
## This need to match | |
ip ospf dead-interval 20 | |
ip ospf area 0.0.0.0 | |
! | |
router ospf | |
## This must not match | |
ospf router-id 192.168.0.7 | |
network 10.6.0.0/24 area 0.0.0.0 | |
network 192.168.0.0/24 area 0.0.0.0 | |
neighbor 10.6.0.1 ## Remote host | |
! | |
line vty | |
! |
This file contains hidden or bidirectional Unicode text that may be interpreted or compiled differently than what appears below. To review, open the file in an editor that reveals hidden Unicode characters.
Learn more about bidirectional Unicode characters
# PFsense with FRR | |
! | |
frr defaults traditional | |
service integrated-vtysh-config | |
! | |
ip router-id 192.168.2.1 | |
! | |
interface tun_wg0 | |
description "ospfd: Remote host" | |
ip ospf network non-broadcast ## This need to set, or it will use broadcast | |
ip ospf hello-interval 5 ### This need to match | |
ip ospf dead-interval 20 ## This need to match | |
ip ospf area 0.0.0.0 | |
interface vtnet0 | |
ip ospf area 0.0.0.0 | |
! | |
router ospf | |
ospf router-id 192.168.2.1 | |
passive-interface vtnet0 | |
network 192.168.2.0/24 area 0.0.0.0 | |
network 10.6.0.0/24 area 0.0.0.0 | |
neighbor 10.6.0.2 | |
! | |
line vty | |
! | |
end |
This file contains hidden or bidirectional Unicode text that may be interpreted or compiled differently than what appears below. To review, open the file in an editor that reveals hidden Unicode characters.
Learn more about bidirectional Unicode characters
tcpdump -i tun_wg0 -n "ip[9] == 89" -vv |
Sign up for free
to join this conversation on GitHub.
Already have an account?
Sign in to comment